Getting error while creating mesh

Have some feature requests, feedback, cool stuff to share, or want to know where FreeCAD is going? This is the place.
Forum rules
Be nice to others! Read the FreeCAD code of conduct!
Post Reply
adarshch
Posts: 4
Joined: Mon Jun 27, 2022 8:19 am

Getting error while creating mesh

Post by adarshch »

I am getting this error while creating the mesh

0.0: We are going to start ...
0.0: Start Gmsh ...
0.1: Gmsh had warnings ...
0.1: Error: Gmsh requires OpenCASCADE to import shape
0.1: Gmsh done!

I am facing this problem since the software is updated. My operating system is Ubuntu Linux.
I have installed OpenCascade. Uninstalled and then installed freecad. But it is still not working.

Please help me on this
User avatar
PrzemoF
Veteran
Posts: 3389
Joined: Fri Jul 25, 2014 4:52 pm
Contact:

Re: Getting error while creating mesh

Post by PrzemoF »

Welcome to the forum!
Can you provide the usual FreeCAD info as well?

Can someone provide info how to chech what gmsh is ising from OpenCASCADE and if there is an easy way of thesting it outside FreeCAD?

Edit: message edited, I missed some info
adarshch
Posts: 4
Joined: Mon Jun 27, 2022 8:19 am

Re: Getting error while creating mesh

Post by adarshch »

Thank You for replying
I am using feecad version 0.20
I am having this issue since the software is updated.
My system is Ubuntu Linux
User avatar
Shalmeneser
Veteran
Posts: 4690
Joined: Wed Dec 23, 2020 12:04 am
Location: Fr

Re: Getting error while creating mesh

Post by Shalmeneser »

Full info : follow link in red banner of Help Forum :

Code: Select all

OS: Windows 10 (10.0)
Word size of FreeCAD: 64-bit
Version: 0.20.28611 (Git)
Build type: Release
Python 3.8.13, Qt 5.12.9, Coin 4.0.0, OCC 7.5.3
Locale: French/France (fr_FR)
Installed mods: 
  * fasteners 0.3.38
  * sheetmetal 0.2.49
adarshch
Posts: 4
Joined: Mon Jun 27, 2022 8:19 am

Re: Getting error while creating mesh

Post by adarshch »

@Shalmeneser

Actually, I am using ubuntu linux. Is there any way to install the older version that is Freecad-0.19?
GeneFC
Veteran
Posts: 3480
Joined: Sat Mar 19, 2016 3:36 pm
Location: Punta Gorda, FL

Re: Getting error while creating mesh

Post by GeneFC »

adarshch wrote: Thu Jun 30, 2022 1:29 pm Actually, I am using ubuntu linux. Is there any way to install the older version that is Freecad-0.19?
Releases all the way back to version 0.13 are available on the github page for FreeCAD

https://github.com/FreeCAD/FreeCAD

Depending on your computer skills these releases may or may not be useful for you.

Gene
chrisb
Veteran
Posts: 43464
Joined: Tue Mar 17, 2015 9:14 am

Re: Getting error while creating mesh

Post by chrisb »

adarshch wrote: Thu Jun 30, 2022 1:29 pm Actually, I am using ubuntu linux.
Then you should try the AppImage.
A Sketcher Lecture with in-depth information is available in English, auf Deutsch, en français, en español.
Post Reply