Crash after start

Have some feature requests, feedback, cool stuff to share, or want to know where FreeCAD is going? This is the place.
Forum rules
Be nice to others! Read the FreeCAD code of conduct!
xadox
Posts: 14
Joined: Wed Mar 09, 2022 12:30 pm

Crash after start

Post by xadox »

Hello, i used FreeCAD for months, but after one day I see crash every time I launch freecad.


FreeCAD version:
FreeCAD 0.19 Revision: 24267 +148 (Git)

Windows version:
OS Name: Microsoft Windows Server 2019 Standard Evaluation
OS Version: 10.0.17763 N/A Build 17763

Code: Select all

$ ./FreeCAD.exe
[5652:4816:0513/142502.444:ERROR:gl_surface_wgl.cc(388)] wglCreatePbufferARB not available.
[5652:4816:0513/142502.444:ERROR:gl_surface_qt.cpp(197)] Requested OpenGL implementation is not supported. Implementation: 1
Illegal storage access...
Unhandled Base::Exception caught in GUIApplication::notify.
The error message is: Illegal storage access! Please save your work under a new file name and restart the application!
Segmentation fault
Logs:
crash.log
(82.99 KiB) Downloaded 14 times
crash.dmp.txt
remove .txt
(187.12 KiB) Downloaded 12 times
wmayer
Founder
Posts: 18643
Joined: Thu Feb 19, 2009 10:32 am

Re: Crash after start

Post by wmayer »

As a very first step try to update your graphic driver. In many cases this fixes the problem.

In case this doesn't help then check: https://forum.freecadweb.org/viewtopic.php?f=4&t=68610
Although this happens on a Linux system the symptoms a very similar to yours and trying to set the option UseSoftwareOpenGL may help.
xadox
Posts: 14
Joined: Wed Mar 09, 2022 12:30 pm

Re: Crash after start

Post by xadox »

wmayer wrote: Thu May 19, 2022 11:09 am Although this happens on a Linux system the symptoms a very similar to yours and trying to set the option UseSoftwareOpenGL may help.
I cannot set any option because app crashed, i saw only loading and then it crashed.

Upd. Looks like I have the similar problem with https://forum.freecadweb.org/viewtopic.php?f=4&t=68610
I cannot update graphic driver because it remote desktop on kvm without any dedicated graphic adapter
xadox
Posts: 14
Joined: Wed Mar 09, 2022 12:30 pm

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by xadox »

wmayer wrote: Wed May 11, 2022 6:32 am
Atticus wrote: Wed May 11, 2022 5:26 am #1 /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so(+0x300f37) [0x7f05853f2f37]
I use the nouveau driver too and by default I also get random crashes when loading the StartPage. What fixed it for me is to set the option of Use Software OpenGL in the preferences.

In case FreeCAD crashes immediately every time you start it then you can also modify your user.cfg by hand. The file is located in $PWD/Settings, now open it with a text editor and search for the content Name="OpenGL". Replace this group with:

Code: Select all

        <FCParamGroup Name="OpenGL">
          <FCBool Name="UseSoftwareOpenGL" Value="1"/>
        </FCParamGroup>
Looks like I have the same problem on Windows. But I couldnt locate folder Settings either or user.cfg. Where I can find it on Windows?
wmayer
Founder
Posts: 18643
Joined: Thu Feb 19, 2009 10:32 am

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by wmayer »

Open the Windows Explorer and type %APPDATA%\FreeCAD into its address bar. There you will find the file.
xadox
Posts: 14
Joined: Wed Mar 09, 2022 12:30 pm

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by xadox »

wmayer wrote: Mon May 23, 2022 8:50 am Open the Windows Explorer and type %APPDATA%\FreeCAD into its address bar. There you will find the file.

Code: Select all

C:\Users\user>cd %APPDATA%\FreeCAD

C:\Users\user\AppData\Roaming\FreeCAD>dir


 C:\Users\user\AppData\Roaming\FreeCAD

13.05.2022  14:31    <DIR>          .
13.05.2022  14:31    <DIR>          ..
18.05.2022  12:05           199 818 crash.dmp
18.05.2022  12:05            84 895 crash.log
13.05.2022  14:25            84 990 crash.log.bak
13.05.2022  13:57    <DIR>          Macro
13.05.2022  13:57    <DIR>          webdata


C:\Users\user\AppData\Roaming\FreeCAD>
There is no file
wmayer
Founder
Posts: 18643
Joined: Thu Feb 19, 2009 10:32 am

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by wmayer »

There is no file
It's probably the application crashes too early. Then a workaround is to move the directory Web tmp. to a different location so that the WebEngine module cannot be loaded. This way FreeCAD should start normally and you can change it in the user settings. Afterwards move the Web folder back.
xadox
Posts: 14
Joined: Wed Mar 09, 2022 12:30 pm

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by xadox »

wmayer wrote: Mon May 23, 2022 11:02 am
There is no file
It's probably the application crashes too early. Then a workaround is to move the directory Web tmp. to a different location so that the WebEngine module cannot be loaded.
I did this, but there is no effect. FreeCad also crashed without creating user.cfg or displaying gui. It created another webdata dir (new) but I don't understand how it can help me.
wmayer
Founder
Posts: 18643
Joined: Thu Feb 19, 2009 10:32 am

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by wmayer »

Add this to user.cfg:

Code: Select all

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<FCParameters>
  <FCParamGroup Name="Root">
    <FCParamGroup Name="BaseApp">
      <FCParamGroup Name="Preferences">
        <FCParamGroup Name="OpenGL">
          <FCBool Name="UseSoftwareOpenGL" Value="1"/>
        </FCParamGroup>
      </FCParamGroup>
    </FCParamGroup>
  </FCParamGroup>
</FCParameters>
adrianinsaval
Veteran
Posts: 2672
Joined: Thu Apr 05, 2018 5:15 pm

Re: Bug: Program received signal SIGSEGV, Segmentation fault.

Post by adrianinsaval »

I assume that means manually creating a user.cfg file with that content?
Post Reply