Assembly3 _ Configuration table and sub-assemblies

Report observations made with the new Toponaming branch.
Post Reply
Medestrac
Posts: 21
Joined: Fri May 04, 2018 5:27 pm

Assembly3 _ Configuration table and sub-assemblies

Post by Medestrac »

I try to learn with assembly3 and the use of links and configuration table...I'm not really sure of the workflow.

As exercise I want to create an assembly made of extruded part (aluminium profile) to do a basic "cuboid frame". I have made the extruded part with a configuration table and 3 sizes: length, width, height for the 3 sides of my cuboid.
I then create an assembly file and import my profile 3 times using the properties "Element count = 4" and "Link Copy on Change = enabled". Then I select the configuration "length" for the first link (x4 parts), the configuration "width" for the second link (x4), and with the configuration "height" for the last link (x4)

I then proceed to create the constraints, but it's quickly a total mess and I don't know which are the elements / constraints anymore.

I re-started and this time I tried to carefully name each element...but it's time consuming and tedious.

I re-started and created an assembly in the profile file, and named the elements in this assembly. Then I import this assembly 3 times in my main assembly, using the same properties "Element count = 4" and "Link Copy on Change = enabled". It's faster because the elements are already named...but when I select a size for a profile, all the parts change, even with "Link copy on change" enabled

So...what is the good workflow to create a configurable cuboid?
User avatar
jpg87
Posts: 667
Joined: Thu Mar 16, 2017 7:16 am
Location: Limoges - France
Contact:

Re: Assembly3 _ Configuration table and sub-assemblies

Post by jpg87 »

Medestrac wrote: Tue Jun 07, 2022 2:41 pm I try to learn with assembly3 ...
A little tutorial I made...
https://forum.freecadweb.org/viewtopic.php?f=20&t=68088
My website : http://help-freecad-jpg87.fr updated 2022/08/01
Medestrac
Posts: 21
Joined: Fri May 04, 2018 5:27 pm

Re: Assembly3 _ Configuration table and sub-assemblies

Post by Medestrac »

This tutorial is really nice, but works well with few parts only, because nothing is named.
I put an understandable label on each part and each element.

For example I create a sub-assembly with a profile part and an element labeled "ProfileTopFace".
I import this sub-assembly in the main assembly and label it "Heigth", with count=2 (so Link_i0 and link_i1)
If I use the element "ProfileTopFace" of the Link_i0 sub_assembly in the main assembly, then the element in the main assembly is automatically named ProfileTopFace@Height@#0...which is totally understandable and automatic BUT I can't change the configuration of the parts in my sub-assemblies

I can label everything understandably manually, but it's quite long and repetitive. I try to get something more "automatic"
Post Reply