OpenSuse Leap 15.4 && FreeCAD 0.19

This subforum is specifically to discuss packaging issues on different platforms (windows, mac, linux), and using different packaging systems (conda, etc...)
Post Reply
AGChigisheff
Posts: 4
Joined: Wed Jun 08, 2022 10:43 am

OpenSuse Leap 15.4 && FreeCAD 0.19

Post by AGChigisheff »

Собственно вот:

FreeCAD 0.19, Libs: 0.19RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2021
FreeCAD is free and open-source software licensed under the terms of LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
.
.
.
.
connect failed: Нет такого файла или каталога (no file ...)
Program received signal SIGSEGV, Segmentation fault.
#0 /lib64/libc.so.6(+0x4ad70) [0x7efdee92dd70]

Возникает при file->create
User avatar
Kunda1
Veteran
Posts: 12743
Joined: Thu Jan 05, 2017 9:03 pm

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by Kunda1 »

Full About info please.
Try with the latest dev version (about to be released) https://github.com/FreeCAD/FreeCAD-Bund ... kly-builds or can use the Snap (edge) or the Flatpak (beta)
Alone you go faster. Together we go farther
Please mark thread [Solved]
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
AGChigisheff
Posts: 4
Joined: Wed Jun 08, 2022 10:43 am

Re: OpenSuse Leap 15.4 && FreeCAD 0.19 || 2.0

Post by AGChigisheff »

FreeCAD_weekly-builds-29045-2022-06-06-conda-Linux-x86_64-py39.AppImage - работает, не ругается
./FreeCAD_weekly-builds-29045-2022-06-06-conda-Linux-x86_64-py39.AppImage
FreeCAD 0.20, Libs: 0.20R29045 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2022
FreeCAD is free and open-source software licensed under the terms of LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
##### #### ### ####
# # # # # #
# ## #### #### # # # # #
#### # # # # # # # ##### # #
# # #### #### # # # # #
# # # # # # # # # ## ## ##
# # #### #### ### # # #### ## ## ##

User path has changed to /home/andreych/.local/share/FreeCAD/. Please move user modules and macros
adrianinsaval
Veteran
Posts: 3194
Joined: Thu Apr 05, 2018 5:15 pm

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by adrianinsaval »

Please post in english, at least using google translate (if doing this post original text too). Right now I don't understand what problem you are having if any.
AGChigisheff
Posts: 4
Joined: Wed Jun 08, 2022 10:43 am

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by AGChigisheff »

It all started after switching from OpenCuse 15.3 to 15.4
File->New
The application crashes.
If run from a terminal
Program received signal SIGSEGV, Segmentation fault.
#0 /lib64/libc.so.6(+0x4ad70) [0x7efdee92dd70]

File->Open
Works until you try to open the selected file.
Error opening work interface.

When running version 0.2 everything works fine. But I didn't get far.
User avatar
onekk
Veteran
Posts: 2820
Joined: Sat Jan 17, 2015 7:48 am
Contact:

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by onekk »

It is not clear what version you use, as in one there is a 0.19.something version, in another a 0.20 version.

If you are using an AppImage, it could be possible that there are version mismatch between the libc on your system and the libc on which FC AppImage is compiled.

There are some reports of mismatch especially on some version that use "rather old" libc or "too bleeding edge".

I have had no problem even if I'm using an Arch Linux distribution that is "rather bleeding edge".

Yuor mileage may vary, as some problem are generated also by the OpenGL framework that on some distribution is causing some problems.

But without a proper error report and version info these are only supposition.

Regards

Carlo D.
My English and Italian Scripting Guide https://github.com/onekk/freecad-doc.
My Blog: https://onekk-maker.blogspot.com/

To help development see on GitHub Page

For enquiry about customized FC Scripting job PM me.
User avatar
Kunda1
Veteran
Posts: 12743
Joined: Thu Jan 05, 2017 9:03 pm

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by Kunda1 »

User has updated OpenSUSE distro and v0.19 has stopped working for them.
Alone you go faster. Together we go farther
Please mark thread [Solved]
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
adrianinsaval
Veteran
Posts: 3194
Joined: Thu Apr 05, 2018 5:15 pm

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by adrianinsaval »

I'm guessing it's the distro package that doesn't work? Either I wouldn't worry much since 0.20 is working and it's becoming the stable version this friday.
AGChigisheff
Posts: 4
Joined: Wed Jun 08, 2022 10:43 am

Re: OpenSuse Leap 15.4 && FreeCAD 0.19

Post by AGChigisheff »

From AppImage all versions work. Weird, but they work. They do not recognize their own figures from the workbench. Not always, but strange things happen.
All the time there are errors in the log (Python). But continues to work. This is both 0.19 and 0.20 versions. Worked under both OpenSuse and Debian 11.
AppImage is a perversion. It is necessary to collect more familiar rpm and deb packages. I'll do it when the time comes. I'll do it when the time comes. In any case, I'll try.
Post Reply