PPA: Addon Manager Warning: Could not import QtWebEngineWidgets, it seems to be missing from your system.

This subforum is specifically to discuss packaging issues on different platforms (windows, mac, linux), and using different packaging systems (conda, etc...)
Post Reply
User avatar
s-light
Posts: 117
Joined: Thu Feb 12, 2015 11:39 am
Location: Germany, Hofheim am Taunus
Contact:

PPA: Addon Manager Warning: Could not import QtWebEngineWidgets, it seems to be missing from your system.

Post by s-light »

Hello at all,

for some time now i get some warnings while starting freecad-daily:

Code: Select all

Addon Manager Warning: Could not import QtWebEngineWidgets, it seems to be missing from your system. 
Please use your system's package manager to install the python3-pyside2.qtwebengine* and python3-pyside2.qtwebchannel packages, 
and if possible alert your package creator to the missing dependency. 
Display of package README will be limited until this dependency is resolved.
i today fixed it by installing the missing dependencies

Code: Select all

stefan@stefan-Zen:~$ apt list python3-pyside2.qtweb*
Listing... Done
python3-pyside2.qtwebchannel/impish,now 5.15.2-1 amd64 [installed]
python3-pyside2.qtwebengine/impish,now 5.15.2-1 amd64 [installed]
python3-pyside2.qtwebenginecore/impish,now 5.15.2-1 amd64 [installed]
python3-pyside2.qtwebenginewidgets/impish,now 5.15.2-1 amd64 [installed]
python3-pyside2.qtwebsockets/impish 5.15.2-1 amd64
so now the warning is gone..

i do not know if this here is the correct place to report this *package* related problem..
please advice me where to report - if somewhere else..

thanks for all your work in this great tool!!!
sunny greetings
stefan



Version:

installed from PPA
http://ppa.launchpad.net/freecad-mainta ... ily/ubuntu

Code: Select all

OS: Ubuntu 21.10 (KDE/plasma)
Word size of FreeCAD: 64-bit
Version: 0.20.
Build type: Release
Branch: unknown
Hash: 35bb6278ea4b93e8a9a67301042a75c065097373
Python 3.9.7, Qt 5.15.2, Coin 4.0.0, OCC 7.5.2
Locale: English/United States (en_US)
Installed mods: 
  * FCGear
  * MakerWorkbench
  * lattice2 1.0.0
  * A2plus 0.4.55
  * sheetmetal
  * BOLTSFC
  * Assembly4 0.11.10
  * ImportNURBS
  * parts_library
  * LCInterlocking
  * InventorLoader 1.3.0
  * Pyramids-and-Polyhedrons
  * kicadStepUpMod 10.11.9
  * ExplodedAssembly

>>> FreeCAD.Version()[4]
'2022/04/13 15:04:00'
Full Log:

Code: Select all

$ freecad-daily 
FreeCAD 0.20, Libs: 0.20R
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2022
FreeCAD is free and open-source software licensed under the terms of LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Sheet Metal workbench loaded
Assembly4 workbench (v0.11.10) loaded
Interlocking laser cut workbench loaded
Addon Manager Warning: Could not import QtWebEngineWidgets, it seems to be missing from your system. Please use your system's package manager to install the python3-pyside2.qtwebengine* and python3-pyside2.qtwebchannel packages, and if possible alert your package creator to the missing dependency. Display of package README will be limited until this dependency is resolved.
('Mod/Pyramids_and_polyhedrons', 'Mod/Pyramids-and-Polyhedrons', 'Mod/FreeCAD-Pyramids-and-Polyhedrons', 'Mod/Pyramids-and-polyhedrons')
Cannot find icon: /Resources/icons/Maker_workbench_icon.svg
connect failed: No such file or directory

Last edited by Kunda1 on Thu Apr 14, 2022 10:39 pm, edited 1 time in total.
Reason: Added 'PPA' to thread title
User avatar
Kunda1
Veteran
Posts: 12746
Joined: Thu Jan 05, 2017 9:03 pm

Re: Addon Manager Warning: Could not import QtWebEngineWidgets, it seems to be missing from your system.

Post by Kunda1 »

I don't want to bug kkremitzki, does anyone else know who has push privileges to the PPA to add QtWebEngineWidgets?
Alone you go faster. Together we go farther
Please mark thread [Solved]
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
User avatar
Kunda1
Veteran
Posts: 12746
Joined: Thu Jan 05, 2017 9:03 pm

Re: PPA: Addon Manager Warning: Could not import QtWebEngineWidgets, it seems to be missing from your system.

Post by Kunda1 »

Mod edit: moved to Packaging subforum
Alone you go faster. Together we go farther
Please mark thread [Solved]
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
Post Reply