[Solved]libboost_filesystem: no file or directory

Having trouble installing or compiling FreeCAD? Get help here.
Post Reply
olividir
Posts: 16
Joined: Sat Oct 30, 2021 9:24 pm

[Solved]libboost_filesystem: no file or directory

Post by olividir »

Hello all

I was trying to start FreeCAD 0.2 (git version in AUR), but ran into this issue:

Code: Select all

❯ FreeCAD
FreeCAD: error while loading shared libraries: libboost_filesystem.so.1.78.0: cannot open shared object file: No such file or directory
Searching the web suggested to reinstall FreeCAD and do a clean build.
The clean build seemed to be going very well, unless the last few lines, I got this error code. I am not sure what means:

Code: Select all

FAILED (errors=3)
==> ERROR: A failure occurred in check().       (100 %)
    Aborting...
 -> error making: freecad-git
The lines before that were just install code. I am not sure how to figure this out, after all, this is the whole error message.
To be clear, I am trying to install freecad-git from AUR. I would show build number if I could, but currently FreeCAD is not installed.

I am on EndeavourOS
Last edited by olividir on Tue Jun 21, 2022 8:41 pm, edited 1 time in total.
chrisb
Veteran
Posts: 43729
Joined: Tue Mar 17, 2015 9:14 am

Re: libboost_filesystem: no file or directory

Post by chrisb »

Please try the AppImage version. It has most (all?) libraries on board.
A Sketcher Lecture with in-depth information is available in English, auf Deutsch, en français, en español.
adrianinsaval
Veteran
Posts: 3194
Joined: Thu Apr 05, 2018 5:15 pm

Re: libboost_filesystem: no file or directory

Post by adrianinsaval »

use --nocheck option when running makepkg or install unofficial precompiled binary from here: https://github.com/adrianinsaval/pacman ... nux-x86_64 (mine) or here: http://mirrors.fossho.st/garuda/repos/c ... ur/x86_64/ (chaotic-aur repo)
Note that the fact that the check fails means there is something wrong with some function of freecad in that build, likely due to some currently incompatible library so if you find something that doesn't work when using the package consider swithcing to the appimage as chrisb suggests
olividir
Posts: 16
Joined: Sat Oct 30, 2021 9:24 pm

Re: libboost_filesystem: no file or directory

Post by olividir »

@adrianinsaval

Thank you for this. I grabbed one of your package and installed. Seems to be working for now. If something breaks, I'll consider appimage.
Solved for now.
adrianinsaval
Veteran
Posts: 3194
Joined: Thu Apr 05, 2018 5:15 pm

Re: [Solved]libboost_filesystem: no file or directory

Post by adrianinsaval »

@olividir if you use the -git version yo should update relatively frequently since it can break when you update your system
Post Reply