3Dconnexion Space Pilot - Rotation/Zoom Issues

Having trouble installing or compiling FreeCAD? Get help here.
Post Reply
pdr0663
Posts: 5
Joined: Thu Dec 03, 2020 6:50 am

3Dconnexion Space Pilot - Rotation/Zoom Issues

Post by pdr0663 »

I pulled out my old SpacePilot with the aim of using it on FreeCAD. It's an older device, but one still supported (just) by an older driver. I've installed the driver, and it works fine on SketchUp (my other CAD system).

I understand that this device works on FreeCAD using the 3Dmouse interface, and indeed I get a response when I operate the mouse. Problem is, I want to change so that zoom is configured on the forward/backward axis of the mouse, not the up/down axis. The driver utility allows me to switch between these two options, and this works for SketchUp. However, it doesn't work for FreeCAD.

Is there a way to manually adjust a configuration file for either 3DxWare or FreeCAD to re-orient the axes?

Windows 10
FreeCAD 0.18
3DxWare driver 10.4.10 Windows 64-bit

Regards,

Paul
pdr0663
Posts: 5
Joined: Thu Dec 03, 2020 6:50 am

Re: 3Dconnexion Space Pilot - Rotation/Zoom Issues

Post by pdr0663 »

Hi, I've managed to solve this myself. I found a reference on another post to customise->Spaceball. Have made changes and it works!

Thanks anyway...

Paul
pdschroder
Posts: 1
Joined: Thu May 12, 2022 12:29 am

Re: 3Dconnexion Space Pilot - Rotation/Zoom Issues

Post by pdschroder »

I haven't been able to find the page you found to fix your problem. I have the same problem as you described.

Edit: I found the answer, and it wasn't in fixing the 3DConnexion driver as I supposed it was. The solution is in FreeCAD itself. Go to Tools>Customize> Spaceball motion or buttons.

I now have the motion working nicely, but I haven't been able to get the buttons to work. I have the Space Pilot default buttons selected, and when I click on one of the buttons on the left panel, the correct function is highlighted on the right, but when I press the buttons on the Space Pilot, nothing happens. Does anyone know what I might be doing wrong?
Last edited by pdschroder on Thu May 12, 2022 1:36 am, edited 2 times in total.
Post Reply