Visual Problem

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

Post Reply
Budahn
Posts: 10
Joined: Fri Jul 01, 2022 9:56 pm

Visual Problem

Post by Budahn »

Hello, Im having mostly a visual problem, when i mesh a cube (just a cube extruded with part design) and make the Open Foam analisys, i realized that when i open it in Paraview to see results these "walls" appear in the middle, like a cross. Does anybody know why this happens? i meshed the cube with gmsh and also refined it.


OS: Windows 10 Version 1903
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.19.24267 +148 (Git)
Build type: Release
Branch: Branch_0.19.4
Hash: 476ecf091941bead59b14e44afa6064d5a66afa3
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.3
Locale: Spanish/Argentina (es_AR)
Attachments
error.png
error.png (76.2 KiB) Viewed 308 times
User avatar
oliveroxtoby
Posts: 645
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Visual Problem

Post by oliveroxtoby »

Budahn wrote: Wed Jul 06, 2022 4:31 pm Hello, Im having mostly a visual problem, when i mesh a cube (just a cube extruded with part design) and make the Open Foam analisys, i realized that when i open it in Paraview to see results these "walls" appear in the middle, like a cross. Does anybody know why this happens? i meshed the cube with gmsh and also refined it.
Maybe try the 'clean to grid' filter in Paraview - see https://forum.freecadweb.org/viewtopic. ... 8&p=557739
Budahn
Posts: 10
Joined: Fri Jul 01, 2022 9:56 pm

Re: Visual Problem

Post by Budahn »

Is there any tutorial that shows how to use it? i´m new to this and i dont really understand what to do exactly or how to apply the filter.

Thanks for the response.
User avatar
oliveroxtoby
Posts: 645
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Visual Problem

Post by oliveroxtoby »

Budahn wrote: Thu Jul 07, 2022 8:03 pm Is there any tutorial that shows how to use it? i´m new to this and i dont really understand what to do exactly or how to apply the filter.

Thanks for the response.
It's added automatically now when you run paraview from CfdOF, so if you update your workbench and try again, the problem should be gone.
Budahn
Posts: 10
Joined: Fri Jul 01, 2022 9:56 pm

Re: Visual Problem

Post by Budahn »

thank you a lot. :) Ramiro
Post Reply