[Fixed] HiSA 1.6.4 Required but the downloaded Zip file is still 1.6.3

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

Post Reply
Syres
Veteran
Posts: 1548
Joined: Thu Aug 09, 2018 11:14 am

[Fixed] HiSA 1.6.4 Required but the downloaded Zip file is still 1.6.3

Post by Syres »

CfdOF Wb version 1.15.0 Dependency check ran after updating both cfMesh and HiSA, still reports HiSA 1.6.4 is required. Looks like the SourceForge Zip file requires updating.

Code: Select all

OS: Linux Mint 19.3 (X-Cinnamon/cinnamon)
Word size of FreeCAD: 64-bit
Version: 0.20.28774 (Git)
Build type: Release
Branch: master
Hash: d2253c7be4db12dbf9b89a53abfacff87692d216
Python 3.6.9, Qt 5.9.5, Coin 4.0.0a, OCC 7.3.0
Locale: English/UnitedKingdom (en_GB)
Installed mods: 
  * fasteners 0.3.40
  * Silk
  * Plot
  * CfdOF 1.15.0
  * BIM 2021.12.0
  * FeedsAndSpeeds 0.4.0
  * dodo
  * Curves 0.4.3
  * Manipulator 1.4.3
  * fcgear 1.0.0
  * ThreadProfile 1.81.0
  * A2plus 0.4.56
  * sheetmetal 0.2.49
Last edited by Syres on Wed May 04, 2022 9:57 am, edited 1 time in total.
User avatar
oliveroxtoby
Posts: 629
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: HiSA 1.6.4 Required but the downloaded Zip file is still 1.6.3

Post by oliveroxtoby »

Syres wrote: Fri Apr 29, 2022 5:54 pm CfdOF Wb version 1.15.0 Dependency check ran after updating both cfMesh and HiSA, still reports HiSA 1.6.4 is required. Looks like the SourceForge Zip file requires updating.
Quite right. Thanks!
Syres
Veteran
Posts: 1548
Joined: Thu Aug 09, 2018 11:14 am

Re: HiSA 1.6.4 Required but the downloaded Zip file is still 1.6.3

Post by Syres »

oliveroxtoby wrote: Fri Apr 29, 2022 7:38 pm Quite right. Thanks!
Sorry for the delay in testing, I tried to install HiSA version 1.6.4 this morning but it's failing unfortunately, I've attached the log.Allwmake zipped up which hopefully will be of use. I updated cfMesh without any issue on the same box last week.

Dependency Checker Output:

Code: Select all

09:54:39  Checking CFD workbench dependencies...
09:54:39  Checking FreeCAD version
09:54:39  Checking for OpenFOAM:
09:54:39  System: Linux
Runtime: Posix
OpenFOAM directory: /opt/openfoam9
09:54:39  Running  echo $WM_PROJECT_VERSION
09:54:39  Raw command:  ['bash', '-c', 'source "/opt/openfoam9/etc/bashrc" && echo $WM_PROJECT_VERSION']
09:54:39  9
09:54:39  Running  wmake -help
09:54:40  Raw command:  ['bash', '-c', 'source "/opt/openfoam9/etc/bashrc" && wmake -help']
09:54:40  
Usage: wmake [OPTION] [dir]
       wmake [OPTION] target [dir [MakeDir]]

options:
  -silent   | -s    Quiet mode (does not echo commands)
  -all      | -a    wmake all sub-directories, running Allwmake if present
  -queue    | -q    wmakeCollect all sub-directories, running Allwmake if present
  -non-stop | -k    Compile without stopping when errors occur
  -j                Compile using all local cores/hyperthreads
  -j <N>    | -j<N> Compile using N cores/hyperthreads
  -no-scheduler     Compile without wmakeScheduler
  -update           Update lnInclude directories, dep files, remove deprecated
                    files and directories
  -help     | -h    Print the usage


A general, easy-to-use make system for multi-platform development
with support for local and network parallel compilation.

The 'target' is a Makefile target:
  e.g., platforms/linux64GccDPOpt/.../fvMesh.o

or a special target:
  all               wmake all sub-directories, running Allwmake if present
  queue             wmakeCollect all sub-directories, running Allwmake if present
  exe               Compile statically linked executable
  lib               Compile statically linked archive lib (.a)
  libo              Compile statically linked lib (.o)
  libso             Compile dynamically linked lib (.so)
  dep               Compile lnInclude and dependencies only
  objects           Compile but not link

09:54:40  Running  cartesianMesh -version
09:54:41  Raw command:  ['bash', '-c', 'source "/opt/openfoam9/etc/bashrc" && cartesianMesh -version']
09:54:41  /*---------------------------------------------------------------------------*\
  =========                 |
  \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox
   \\    /   O peration     | Website:  https://openfoam.org
    \\  /    A nd           | Version:  9
     \\/     M anipulation  |
\*---------------------------------------------------------------------------*/
Build  : 9-b456138dc4bc
Exec   : cartesianMesh -version
Date   : May 03 2022
Time   : 09:54:40
Host   : "john-System-Product-Name"
PID    : 28390
09:54:41  I/O    : uncollated
Case   : /home/john
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 10)
allowSystemOperations : Allowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
cfMesh-CfdOF (cfMesh 1.1.2) 1.16
09:54:41  Running  hisa -version
09:54:41  Raw command:  ['bash', '-c', 'source "/opt/openfoam9/etc/bashrc" && hisa -version']
09:54:41  /bin/bash: hisa: command not found
09:54:41  HiSA not found
09:54:42  Checking for paraview:
09:54:42  Paraview executable: /opt/paraviewopenfoam56/bin/paraview
09:54:42  Checking Plot module:
09:54:42  Could not load Plot module
Attempting to use Plot workbench instead
09:54:42  Checking for gmsh:
09:54:42  gmsh executable: /home/john/Downloads/gmsh-4.9.2-Linux64/bin/gmsh
09:54:42  Running  '/home/john/Downloads/gmsh-4.9.2-Linux64/bin/gmsh' -version
09:54:42  Raw command:  ['bash', '-c', 'source "/opt/openfoam9/etc/bashrc" && \'/home/john/Downloads/gmsh-4.9.2-Linux64/bin/gmsh\' -version']
09:54:42  4.9.2
09:54:42  Completed CFD dependency check

Code: Select all

OS: Linux Mint 19.3 (X-Cinnamon/cinnamon)
Word size of FreeCAD: 64-bit
Version: 0.20.28788 (Git)
Build type: Release
Branch: master
Hash: 583916a2e54c880df9bcaaba6b1658371a5297bb
Python 3.6.9, Qt 5.9.5, Coin 4.0.0a, OCC 7.3.0
Locale: English/UnitedKingdom (en_GB)
Installed mods: 
  * fasteners 0.3.41
  * Silk
  * Plot 2022.4.17
  * CfdOF 1.15.0
  * BIM 2021.12.0
  * FeedsAndSpeeds 0.4.0
  * dodo
  * Curves 0.4.3
  * Manipulator 1.4.3
  * fcgear 1.0.0
  * ThreadProfile 1.81.0
  * A2plus 0.4.56
  * sheetmetal 0.2.49
Attachments
log.Allwmake.zip
(4.39 KiB) Downloaded 16 times
User avatar
oliveroxtoby
Posts: 629
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: HiSA 1.6.4 Required but the downloaded Zip file is still 1.6.3

Post by oliveroxtoby »

Syres wrote: Tue May 03, 2022 8:56 am Sorry for the delay in testing, I tried to install HiSA version 1.6.4 this morning but it's failing unfortunately, I've attached the log.Allwmake zipped up which hopefully will be of use. I updated cfMesh without any issue on the same box last week.
Hopefully resolved now. It's always a bit of a chore keeping compatibility with several different OpenFOAM versions, so I appreciate the testing! Thanks!
Syres
Veteran
Posts: 1548
Joined: Thu Aug 09, 2018 11:14 am

Re: HiSA 1.6.4 Required but the downloaded Zip file is still 1.6.3

Post by Syres »

oliveroxtoby wrote: Tue May 03, 2022 5:59 pm Hopefully resolved now.
Version 1.6.6 is now installed successfully, thanks.
Post Reply