Installation problem 0.19_pre: CFD dependency check fails

A subforum specific to the development of the OpenFoam-based workbenches ( Cfd https://github.com/qingfengxia/Cfd and CfdOF https://github.com/jaheyns/CfdOF )

Moderator: oliveroxtoby

User avatar
oliveroxtoby
Posts: 645
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by oliveroxtoby »

Roland wrote: Wed Mar 24, 2021 11:14 pm
oliveroxtoby wrote: Mon Mar 22, 2021 7:14 pm
Roland wrote: Sun Mar 21, 2021 4:12 pm I am still getting an issue. Upon running the solver, OpenFOAM gives this message:
16:41:08 --> FOAM Warning :
From void* Foam::dlLibraryTable::openLibrary(const Foam::fileName&, bool)
in file db/dynamicLibrary/dlLibraryTable/dlLibraryTable.C at line 188
Could not load "libmomentumTransportModels.so"
Error 948576: `y
This can be ignored for now. It was a quick fix for compatibility with OpenFOAM v8. I'll sort it out properly when I get some time.
Hi Oliver,

Perhaps I found the cause of this error. Upon inspection of controlDict, I saw this code at file end:
libs
(
// Needed for availability of porous baffle boundary in potentialFoam
"libturbulenceModels.so"
"libmomentumTransportModels.so"
);
I'm not sure what this means. Perhaps a reminder for you as a coder of a task to do? Or a typo?

Anyway, I just reported it here for in case that it could be of help.

Best regards,

Roland
Hi Roland

I fixed the issue a couple of days ago - please update your workbench.
User avatar
Roland
Posts: 333
Joined: Fri Aug 21, 2015 2:20 pm

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by Roland »

Code: Select all

I fixed the issue a couple of days ago - please update your workbench.
Shall do. Thx!
oat
Posts: 1
Joined: Thu Apr 29, 2021 4:18 am

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by oat »

The problem also recently happened to me. However, I can solve it. Let's try this. Instead of installing the openfoam in the FD preference, download and run the OpenFOAM® MinGW and install Microsoft MPI. You will be asked to install Microsoft MPI, when installing the openfoam.
Gena00X
Posts: 2
Joined: Thu Jul 22, 2021 8:14 am

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by Gena00X »

Hello.
I'm sorry, the question is probably stupid. And it may have already been discussed earlier.
But I couldn't find anything similar to such an error.
And I am sorry, my English may be not very good.

I installed FreeCFD, the CfdOF plugin for it and then installed the dependencies through the plugin menu.
In accordance with this manual, the windows section https://github.com/jaheyns/CfdOF
Operating system windows 10 x64

I have error during dependency check.

Code: Select all

 Checking for gmsh:
12:53:06  C:/Program Files/FreeCAD 0.19/bin/gmsh.exe
12:53:06  Running  'C:/Program Files/FreeCAD 0.19/bin/gmsh.exe' -version
12:53:06  Raw command:  ['C:/Program Files/FreeCAD 0.19/bin\\python.exe', '-u', 'C:\\Users\\79031\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\WindowsRunWrapper.py', 'C:\\Program Files\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', "echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; 'C:/Program Files/FreeCAD 0.19/bin/gmsh.exe' -version"]
12:53:06  Sourcing OpenFOAM environment...
12:53:06  openfoam: windows support (mingw64) is runtime only
12:56:39  4.8.3
12:56:39  Traceback (most recent call last):
12:56:39    File "C:\Users\79031\AppData\Roaming\FreeCAD\Mod\CfdOF\CfdPreferencePage.py", line 219, in runDependencyChecker
12:56:39      msg = CfdTools.checkCfdDependencies()
12:56:39    File "C:\Users\79031\AppData\Roaming\FreeCAD\Mod\CfdOF\CfdTools.py", line 1042, in checkCfdDependencies
12:56:39      if int(versionlist[0]) < 2 or (int(versionlist[0]) == 2 and int(versionlist[1]) < 13):
12:56:39  ValueError: invalid literal for int() with base 10: 'environment'
What could have caused the error?

Output from FreeCAD report window:

Code: Select all

12:47:45  Checking CFD workbench dependencies...
12:47:45  Checking FreeCAD version
12:47:45  Checking for OpenFOAM:
12:47:45  OpenFOAM directory: C:\Program Files\ESI-OpenCFD\OpenFOAM\v2012
12:47:45  System: Windows
12:47:45  Runtime: MinGW
12:47:45  Running  echo $FOAM_API
12:47:45  Raw command:  ['C:/Program Files/FreeCAD 0.19/bin\\python.exe', '-u', 'C:\\Users\\79031\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\WindowsRunWrapper.py', 'C:\\Program Files\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; echo $FOAM_API']
12:47:45  Sourcing OpenFOAM environment...
12:47:45  openfoam: windows support (mingw64) is runtime only
12:49:03  2012
12:49:03  Running  cartesianMesh -version
12:49:06  Raw command:  ['C:/Program Files/FreeCAD 0.19/bin\\python.exe', '-u', 'C:\\Users\\79031\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\WindowsRunWrapper.py', 'C:\\Program Files\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; cartesianMesh -version']
12:49:06  Sourcing OpenFOAM environment...
12:49:06  openfoam: windows support (mingw64) is runtime only
12:50:29  /*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  v2012                                 |
|   \\  /    A nd           | Website:  www.openfoam.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 79e353b84e-20201222 OPENFOAM=2012
Arch   : "LSB;label=32;scalar=64"
Exec   : C:\Program Files\ESI-OpenCFD\OpenFOAM\v2012\msys64\home\ofuser\OpenFOAM\OpenFOAM-v2012\platforms\win64MingwDPInt32Opt\bin\cartesianMesh.exe -version
Date   : Jul 22 2021
Time   : 12:50:29
Host   : LAPTOP-BNTPSAF1
PID    : 5352
I/O    : uncollated
Case   : C:/Program Files/ESI-OpenCFD/OpenFOAM/v2012/msys64/home/ofuser
nProcs : 1
trapFpe: Floating point exception trapping enabled (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 5, maxFileModificationPolls 20)
allowSystemOperations : Allowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
cfMesh-CfdOF (cfMesh 1.1.2) 1.8
12:50:29  Running  hisa -version
12:50:32  Raw command:  ['C:/Program Files/FreeCAD 0.19/bin\\python.exe', '-u', 'C:\\Users\\79031\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\WindowsRunWrapper.py', 'C:\\Program Files\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; hisa -version']
12:50:32  Sourcing OpenFOAM environment...
12:50:33  openfoam: windows support (mingw64) is runtime only
12:52:51  /*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  v2012                                 |
|   \\  /    A nd           | Website:  www.openfoam.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 79e353b84e-20201222 OPENFOAM=2012
Arch   : "LSB;label=32;scalar=64"
Exec   : C:\Program Files\ESI-OpenCFD\OpenFOAM\v2012\msys64\home\ofuser\OpenFOAM\OpenFOAM-v2012\platforms\win64MingwDPInt32Opt\bin\hisa.exe -version
Date   : Jul 22 2021
Time   : 12:52:51
Host   : LAPTOP-BNTPSAF1
PID    : 16084
I/O    : uncollated
Case   : C:/Program Files/ESI-OpenCFD/OpenFOAM/v2012/msys64/home/ofuser
nProcs : 1
trapFpe: Floating point exception trapping enabled (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 5, maxFileModificationPolls 20)
allowSystemOperations : Allowing user-supplied system call operations

12:52:51  // * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
hisa 1.4.2
12:52:52  Checking for paraview:
12:53:06  Checking for Plot workbench:
12:53:06  Checking for gmsh:
12:53:06  C:/Program Files/FreeCAD 0.19/bin/gmsh.exe
12:53:06  Running  'C:/Program Files/FreeCAD 0.19/bin/gmsh.exe' -version
12:53:06  Raw command:  ['C:/Program Files/FreeCAD 0.19/bin\\python.exe', '-u', 'C:\\Users\\79031\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\WindowsRunWrapper.py', 'C:\\Program Files\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', "echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; 'C:/Program Files/FreeCAD 0.19/bin/gmsh.exe' -version"]
12:53:06  Sourcing OpenFOAM environment...
12:53:06  openfoam: windows support (mingw64) is runtime only
12:56:39  4.8.3
12:56:39  Traceback (most recent call last):
12:56:39    File "C:\Users\79031\AppData\Roaming\FreeCAD\Mod\CfdOF\CfdPreferencePage.py", line 219, in runDependencyChecker
12:56:39      msg = CfdTools.checkCfdDependencies()
12:56:39    File "C:\Users\79031\AppData\Roaming\FreeCAD\Mod\CfdOF\CfdTools.py", line 1042, in checkCfdDependencies
12:56:39      if int(versionlist[0]) < 2 or (int(versionlist[0]) == 2 and int(versionlist[1]) < 13):
12:56:39  ValueError: invalid literal for int() with base 10: 'environment'
thschrader
Veteran
Posts: 2626
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by thschrader »

Gena00X wrote: Thu Jul 22, 2021 11:07 am ...
Operating system windows 10 x64
...
Hi Gena00X,
welcome to the forum!
You run on windows, you should try this (not ESI):
https://bluecfd.github.io/Core/Downloads/

https://forum.freecadweb.org/viewtopic.php?f=36&t=52381

EDIT:
lets do some promotion for FS-Dynamics, sponsor of bluecfd
https://fsdynamics.se/cfd/
Ola...

Hope that helps.
Questions welcome.
User avatar
oliveroxtoby
Posts: 645
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by oliveroxtoby »

Gena00X wrote: Thu Jul 22, 2021 11:07 am
What could have caused the error?
I think this was a bug. Should be fixed now if you update your workbench.
Gena00X
Posts: 2
Joined: Thu Jul 22, 2021 8:14 am

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by Gena00X »

thschrader wrote: Thu Jul 22, 2021 6:56 pm Hi Gena00X,
welcome to the forum!
You run on windows, you should try this (not ESI):
Thanks. It looks pretty good, I'll really give it a try.
oliveroxtoby wrote: Thu Jul 22, 2021 7:23 pm
Gena00X wrote: Thu Jul 22, 2021 11:07 am
What could have caused the error?
I think this was a bug. Should be fixed now if you update your workbench.
Yes, after the update CfdOF, the dependency check was successfully completed
Sheidogis
Posts: 2
Joined: Sat Feb 19, 2022 6:26 pm

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by Sheidogis »

Hi i also get a similar problem with freecad 0.19.2 (and 0.20 build 27422) and the latest CFDof (1.10.2) on win 10

Any ideas?

Code: Select all

20:10:06  Sourcing OpenFOAM environment...
20:10:06  openfoam: windows support (mingw64) is runtime only
20:10:31  4.9.4
20:10:31  Traceback (most recent call last):
20:10:31    File "C:\Users\Christian\AppData\Roaming\FreeCAD\Mod\CfdOF\.\CfdPreferencePage.py", line 240, in runDependencyChecker
20:10:31      msg = CfdTools.checkCfdDependencies()
20:10:31    File "C:\Users\Christian\AppData\Roaming\FreeCAD\Mod\CfdOF\.\CfdTools.py", line 1056, in checkCfdDependencies
20:10:31      if int(versionlist[0]) < 2 or (int(versionlist[0]) == 2 and int(versionlist[1]) < 13):
20:10:32  ValueError: invalid literal for int() with base 10: 'only'
full log

Code: Select all

20:08:46  Checking CFD workbench dependencies...
20:08:46  Checking FreeCAD version
20:08:46  Checking for OpenFOAM:
20:08:46  OpenFOAM directory: C:\Users\Christian\AppData\Roaming\ESI-OpenCFD\OpenFOAM\v2012
20:08:46  System: Windows
20:08:46  Runtime: MinGW
20:08:46  Running  echo $FOAM_API
20:08:46  Raw command:  ['C:/Program Files/FreeCAD 0.20/bin\\python.exe', '-u', 'C:\\Users\\Christian\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\.\\WindowsRunWrapper.py', 'C:\\Users\\Christian\\AppData\\Roaming\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; echo $FOAM_API']
20:08:46  Sourcing OpenFOAM environment...
20:08:46  openfoam: windows support (mingw64) is runtime only
20:09:11  2012
20:09:11  Running  cartesianMesh -version
20:09:13  Raw command:  ['C:/Program Files/FreeCAD 0.20/bin\\python.exe', '-u', 'C:\\Users\\Christian\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\.\\WindowsRunWrapper.py', 'C:\\Users\\Christian\\AppData\\Roaming\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; cartesianMesh -version']
20:09:13  Sourcing OpenFOAM environment...
20:09:13  openfoam: windows support (mingw64) is runtime only
20:09:38  /*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  v2012                                 |
|   \\  /    A nd           | Website:  www.openfoam.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 79e353b84e-20201222 OPENFOAM=2012
Arch   : "LSB;label=32;scalar=64"
Exec   : C:\Users\Christian\AppData\Roaming\ESI-OpenCFD\OpenFOAM\v2012\msys64\home\ofuser\OpenFOAM\OpenFOAM-v2012\platforms\win64MingwDPInt32Opt\bin\cartesianMesh.exe -version
Date   : Feb 19 2022
Time   : 20:09:38
Host   : 
PID    : 10104
I/O    : uncollated
Case   : C:/Users/Christian/AppData/Roaming/ESI-OpenCFD/OpenFOAM/v2012/msys64/home/ofuser
nProcs : 1
trapFpe: Floating point exception trapping enabled (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 5, maxFileModificationPolls 20)
allowSystemOperations : Allowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
cfMesh-CfdOF (cfMesh 1.1.2) 1.8
20:09:38  Running  hisa -version
20:09:39  Raw command:  ['C:/Program Files/FreeCAD 0.20/bin\\python.exe', '-u', 'C:\\Users\\Christian\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\.\\WindowsRunWrapper.py', 'C:\\Users\\Christian\\AppData\\Roaming\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', 'echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; hisa -version']
20:09:39  Sourcing OpenFOAM environment...
20:09:39  openfoam: windows support (mingw64) is runtime only
20:10:04  /*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  v2012                                 |
|   \\  /    A nd           | Website:  www.openfoam.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 79e353b84e-20201222 OPENFOAM=2012
Arch   : "LSB;label=32;scalar=64"
Exec   : C:\Users\Christian\AppData\Roaming\ESI-OpenCFD\OpenFOAM\v2012\msys64\home\ofuser\OpenFOAM\OpenFOAM-v2012\platforms\win64MingwDPInt32Opt\bin\hisa.exe -version
Date   : Feb 19 2022
Time   : 20:10:04
Host   :
PID    : 6480
I/O    : uncollated
Case   : C:/Users/Christian/AppData/Roaming/ESI-OpenCFD/OpenFOAM/v2012/msys64/home/ofuser
nProcs : 1
trapFpe: Floating point exception trapping enabled (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 5, maxFileModificationPolls 20)
allowSystemOperations : Allowing user-supplied system call operations

20:10:04  // * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
hisa 1.4.2
20:10:04  Checking for paraview:
20:10:06  Checking Plot module:
20:10:06  Checking for gmsh:
20:10:06  Running  'C:/Program Files/gmsh-4.9.4-Windows64/gmsh.exe' -version
20:10:06  Raw command:  ['C:/Program Files/FreeCAD 0.20/bin\\python.exe', '-u', 'C:\\Users\\Christian\\AppData\\Roaming\\FreeCAD\\Mod\\CfdOF\\.\\WindowsRunWrapper.py', 'C:\\Users\\Christian\\AppData\\Roaming\\ESI-OpenCFD\\OpenFOAM\\v2012\\msys64\\usr\\bin\\bash', '--login', '-O', 'expand_aliases', '-c', "echo Sourcing OpenFOAM environment...; source $HOME/OpenFOAM/OpenFOAM-v2012/etc/bashrc; export PATH=$FOAM_LIBBIN/msmpi:$FOAM_LIBBIN:$WM_THIRD_PARTY_DIR/platforms/linux64MingwDPInt32/lib:$PATH; 'C:/Program Files/gmsh-4.9.4-Windows64/gmsh.exe' -version"]
20:10:06  Sourcing OpenFOAM environment...
20:10:06  openfoam: windows support (mingw64) is runtime only
20:10:31  4.9.4
20:10:31  Traceback (most recent call last):
20:10:31    File "C:\Users\Christian\AppData\Roaming\FreeCAD\Mod\CfdOF\.\CfdPreferencePage.py", line 240, in runDependencyChecker
20:10:31      msg = CfdTools.checkCfdDependencies()
20:10:31    File "C:\Users\Christian\AppData\Roaming\FreeCAD\Mod\CfdOF\.\CfdTools.py", line 1056, in checkCfdDependencies
20:10:31      if int(versionlist[0]) < 2 or (int(versionlist[0]) == 2 and int(versionlist[1]) < 13):
20:10:32  ValueError: invalid literal for int() with base 10: 'only'
User avatar
oliveroxtoby
Posts: 645
Joined: Fri Dec 23, 2016 9:43 am
Location: South Africa

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by oliveroxtoby »

Sheidogis wrote: Sat Feb 19, 2022 7:12 pm Hi i also get a similar problem with freecad 0.19.2 (and 0.20 build 27422) and the latest CFDof (1.10.2) on win 10

Any ideas?
I can't figure out why this would be happening on your system, but I've made a change that might help...
Sheidogis
Posts: 2
Joined: Sat Feb 19, 2022 6:26 pm

Re: Installation problem 0.19_pre: CFD dependency check fails

Post by Sheidogis »

Thank you for the feedback and the great tool.
I think i was able to track the issue down to gmsh version 4.9.4.When using gmsh 4.8.4 it works fine.
With the latest update of CfdOF using gmsh 4.9.4 also works fine. many thanks
Post Reply