Known OS specific Issues

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
Posts: 43589
Joined: Tue Mar 17, 2015 9:14 am

Known OS specific Issues

Post by chrisb »

This topic is locked. For comments go to

For modeling issues please refer to the Frequently asked questions and the Troubleshooting models
  • General issues
    • Errors in Step exports with FreeCAD 0.19
      Solution: upgrade to FreeCAD 0.19.4 or to a current 0.20 version.
    • All self compiled versions and packages created by other distributions
      There are issues when using Python 3.10.x. If you compile yourself you may have to use Python 3.8 instead. For further details see .
    • If the AddonManager complains of no connection to Github
      To test the connection between FreeCAD and Github (where we currently host many Addons, type the following in to the Python console

      Code: Select all

      import urllib.request
      r = urllib.request.urlopen("")
      A reply like b'Design for failure.' indicates the connection is working.
  • Linux

    1. FreeCAD starts with the splash screen, but doesn't show anything further.

      Starting from the command line one of the following errors (and more) is shown:

      Code: Select all

      libGL error: MESA-LOADER: failed to open radeonsi:

      Code: Select all

      libGL error: MESA-LOADER: failed to open iris:

      Code: Select all

      libGL error: failed to load driver: swrast
      More errors involving ar likely.

      Before starting from the command line, set the environment variable LD_PRELOAD. You may have to adapt the following to match your system:

      Code: Select all

      LD_PRELOAD=/usr/lib/x86_64-linux-gnu/ ./FreeCAD_weekly-builds-27936-Linux-Conda_glibc2.12-x86_64.AppImage
    2. Freecad crashes on loading, sometimes loads and crashes almost immediately afterwards, sometimes opens for a short time but soon crashes.(tested on 0.20)

      Hardware affected: nvidia graphic cards
      Problem: When running from terminal, might report:

      Code: Select all

      FreeCAD 0.20, Libs: 0.20R26720 (Git)
      ... clipped...
      nouveau: kernel rejected pushbuf: No such file or directory
      nouveau: ch5: krec 0 pushes 0 bufs 1 relocs 0
      nouveau: ch5: buf 00000000 00000002 00000004 00000004 00000000 0x7f2c0812b000 0x30000 0x80000
      Program received signal SIGSEGV, Segmentation fault.
      Program received signal SIGSEGV, Segmentation fault.
      #0  /lib/x86_64-linux-gnu/ [0x7f2c122a6210]
      /tmp/.mount_FreeCAYIY0GE/AppRun: line 41:  6296 Segmentation fault      ${MAIN} "$@"
      Sometimes just updating nvidia drivers works, but the best/proven working option (if possible) is to change to "Use Software OpenGL" in Preferences.

      Forum Discussion (links to specific posts): ... 25#p558116 ... 80#p546204
    3. Errors occur when creating a Path Job, other workbenches work well
      The error message is

      Code: Select all

      09:45:18  PathJobGui.ERROR: function takes exactly 2 arguments (1 given)
      09:45:18  Traceback (most recent call last):
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 1363, in Create
          obj = PathJob.Create('Job', base, template)
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 509, in Create
          obj.Proxy = ObjectJob(obj, models, templateFile)
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 155, in __init__
          self.setupBaseModel(obj, models)
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 190, in setupBaseModel
          model.addObjects([createModelResourceClone(obj, base) for base in models])
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 190, in <listcomp>
          model.addObjects([createModelResourceClone(obj, base) for base in models])
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 98, in createModelResourceClone
          return createResourceClone(obj, orig, 'Model', 'BaseGeometry')
      09:45:18    File "/usr/share/freecad-daily/Mod/Path/PathScripts/", line 84, in createResourceClone
          clone = Draft.clone(orig)
      09:45:18    File "/usr/share/freecad-daily/Mod/Draft/draftmake/", line 111, in make_clone
      09:45:18  TypeError: function takes exactly 2 arguments (1 given)
      Solution This is caused by multiple Python versions. According to ... 69#p495752 this can be fixed:
      • remove freecad-python3 libfreecad-python3-0.18
      • reinstall freecad-daily-python3 libfreecad-daily-python3-0.19
    4. AppImage fails to open with a segmentation fault; observed on a Mageia system, see

      The error message is

      Code: Select all

      Loading Assembly4 WorkBench
      Program received signal SIGSEGV, Segmentation fault.
      #0  /lib64/ [0x7fdc530c6af0]
      #1  /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/ [0x7fdc4cc9ab27]
      #2  /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/ [0x7fdc4cc9ab47]
      #3  0x7fdc4cc9a575 in QXcbNativeInterface::addHandler(QXcbNativeInterfaceHandler*) from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #4  /usr/lib64/qt5/plugins/xcbglintegrations/ [0x7fdc47f7f179]
      #5  /usr/lib64/qt5/plugins/xcbglintegrations/ [0x7fdc47f7b57a]
      #6  0x7fdc4cc869d6 in QXcbConnection::glIntegration() const from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #7  0x7fdc4cc877e6 in QXcbIntegration::createPlatformOpenGLContext(QOpenGLContext*) const from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #8  0x7fdc539b53e9 in QOpenGLContext::create() from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #9  0x7fdc5398fde9 in QGuiApplicationPrivate::init() from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #10  0x7fdc53e18c13 in QApplicationPrivate::init() from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #11  0x7fdc5592d1c2 in Gui::GUIApplicationNativeEventAware::GUIApplicationNativeEventAware(int&, char**) from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #12  0x7fdc5592ba72 in Gui::GUIApplication::GUIApplication(int&, char**) from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #13  0x7fdc5592c94a in Gui::GUISingleApplication::GUISingleApplication(int&, char**) from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #14  0x7fdc558a17b4 in Gui::Application::runApplication() from /tmp/.mount_FreeCAwBx8F0/usr/bin/../lib/
      #15  /tmp/.mount_FreeCAwBx8F0/usr/bin/freecad(+0x37cd) [0x5594ce4147cd]
      #16  /lib64/ [0x7fdc530b0b0b]
      #17  /tmp/.mount_FreeCAwBx8F0/usr/bin/freecad(+0x4521) [0x5594ce415521]
      Before starting unset the environment variable QT_PLUGIN_PATH

      Code: Select all

      unset QT_PLUGIN_PATH
      This could be done in a special batch file or on one of the startup scripts.
    5. Ubuntu does not show *.FCStd files and does not use the file extension on saving
      This is an issue with the system file selection dialog. From another topic:
      wmayer wrote: Sun Jan 27, 2019 11:23 am The problem is somehow with the native file dialog on some DEs (Desktop Environments).
      The easiest would be to upgrade to v0.18 where we have added an option to change at
      runtime between the native and Qt file dialog.
      1. Open the Parameter editor from the Tools menu
      2. Navigate to BaseApp/Preferences/Dialog
      3. Create a boolean parameter named: DontUseNativeDialog and set it to true.
    6. Startup fails on Debian based system like Ubuntu, Debian, Mint, ...
      FreeCAD startup may fail with the message

      Code: Select all

      failed to create drawable
      [xcb] Unknown sequence number while processing queue
      [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
      [xcb] Aborting, sorry about that.
      freecad: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
      Workaround: Launch FreeCAD from the command line terminal:
      gntech wrote: Thu Apr 12, 2018 6:04 pm A workaround is to disable DRI3 just for FreeCAD by launching FreeCAD from the terminal with the following command.

      Code: Select all

      LIBGL_DRI3_DISABLE=true freecad
    7. Crash on Debian based systems importing SVG
      Hint from NormandC: The current PPAs fix this by upgrading some dependencies. Users who previously implemented Chris_G's fix mentioned below should revert the change (unlock the expat/libexpat1 packages and update them to the version in the Ubuntu 18.04/18.10 repo) for the PPA update to succeed.

      Outdated message:
      FreeCAD can crash when importing SVG files with a message like
      jalar wrote: Wed Jan 10, 2018 1:19 pm

      Code: Select all

      openat(AT_FDCWD, "/path-to-file.svg", O_RDONLY) = 27
      fstat(27, {st_mode=S_IFREG|0644, st_size=2234752, ...}) = 0
      --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x3a9} ---
      write(2, "\33[1;31m", 7)                = 7
      write(2, "Program received signal SIGSEGV,"..., 53Program received signal SIGSEGV, Segmentation fault.
      ) = 53
      #0  /lib/x86_64-linux-gnu<br />
      / [0x7fd97f382140]
      #1  /lib/x86_64-linux-gnu/ [0x7fd976c411cb]
      #2  /usr/lib/python2.7/lib-dynload/ [0x7fd90487a968]
      Workaround: As a solution some libraries have to be installed manually:
      Chris_G wrote: Thu Apr 19, 2018 8:45 am The packages from Ubuntu xenial work fine :
      I have also this one, but I don't know if it is really needed :

      Then in the folder where you downloaded the packages :

      Code: Select all

      sudo dpkg -i ./expat_2.1.0-7ubuntu0.16.04.3_amd64.deb
      sudo echo expat hold | sudo dpkg --set-selections
      sudo dpkg -i ./libexpat1_2.1.0-7ubuntu0.16.04.3_amd64.deb
      sudo echo libexpat1 hold | sudo dpkg --set-selections
      sudo dpkg -i ./libexpat1-dev_2.1.0-7ubuntu0.16.04.3_amd64.deb
      sudo echo libexpat1-dev hold | sudo dpkg --set-selections
    8. Spacenav Mouse Issues Some users are reporting that they can't use their 3Dconnexion input devices on different Linux distros.
      (ref: thread 1, thread 2)
      Workaround: A user seems to have fixed it, seems like it was permissions issue: ... 27#p341327
    9. Crash when loading a file
      When loading a FreeCAD file the program crashes before displaying the model with the message

      Code: Select all

      Program received signal SIGSEGV, Segmentation fault.
      #0  /lib/x86_64-linux-gnu/ [0x7f1b4bd56210]
      #1  /usr/lib/x86_64-linux-gnu/dri/ [0x7f1b3ce4dc14]
      #5  /usr/lib/x86_64-linux-gnu/dri/ [0x7f1b3c4688d4]
      #6  0x7f1b4a8ac8d8 in QPlatformBackingStore::composeAndFlush(QWindow*, QRegion const&, QPoint const&, QPlatformTextureList*, bool) from /lib/x86_64-linux-gnu/
      Set the environment variable

      Code: Select all

      See ... untu-20-04
    10. Crash on Arch Linux.

      Workaround: Downgrade Mesa versions:

      Code: Select all

      sudo pacman downgrade
      sudo downgrade mesa
    11. Self compiled OpenCamLib OCL doesn't work, although compilation is successful

      Solution: unlike in the Windows installation, the name of the directory shouldn't be named in uppercase letters, see ... 96#p537059.
  • ChromeBook / ChromeOS
    Chromebook can rund the Linux versions of FreeCAD, e.g. the AppImage.
    1. Starting FreeCAD seems ok, but when trying to create or open file, it doesn't respond anymore.

      Workaround: Disable GPU acceleration. In a terminal set

      Code: Select all

      before starting FreeCAD. Look at ... n_per_app/ to learn how to do it permanently.

      Corresponding forum post.
  • Windows
    1. FreeCAD not responding beyond splash screen when using multiple monitors. . (added 2022-07-02)

      This can be caused by Qt, and can at least partially be fixed by editing in the Windows registry the value of HKEY_CURRENT_USER\SOFTWARE\FreeCAD\Qt5.15. For details see
    2. Addon manager does not work on windows with special characters in the username. (added 2022-06-28)

      Install manually to %APPDATA%\Roaming\FreeCAD\Mod.
    3. After editing some preferences FreeCAD uses a different File Selection Dialog
      See also in the Linux section and ... 40#p498240.

      a) Open the Parameter editor from the Tools menu
      b) Navigate to BaseApp/Preferences/Dialog
      c) Create a boolean parameter named: DontUseNativeDialog and set it to true.
    4. Chocolatey installation problems
      Workaround: See this forum post.
    5. [WinError 127] The specified procedure could not be found, followed by a path to "shiboken2".
      This is caused by having installed multiple versions of python, see ... 12#p491312

      Solution: remove all but one Python versions. including their config files in %APPDATA%\Roaming, see also the question below "FreeCAD does not start or doesn't open certain workbenches".
    6. The change from Qt4 to Qt5 can cause issues on Windows:
      wmayer wrote: Fri May 03, 2019 11:17 am The responsible change that could explain the behaviour is the move from Qt4 to Qt5. Qt5 has a module QtOpenGL kept for backward compatibility but it's recommended not to use it and instead to port old code to the new API. At the beginning when we moved to Qt5 we used this module but it caused several problems and we then ported our code using the recommended API.

      Under the hood the implementation of OpenGL support in Qt5 has changed a lot and it's hard to say what at the end is responsible if something doesn't work. But as said above in most cases it's the graphic driver that causes problems.
      For more information also have a look here: ... cs-drivers Maybe you can get it to work by setting the variable QT_OPENGL

      Workaround: If you face weird behaviour concerning mouse movements, menus disappearing, black windows, try the Qt4 variant of the development version. Important Note: The Win 0.19_pre QT4 version is getting old. During 0.19 some C++ stuff was added that the QT4/VS2013 libpack does not support. So there will be no further updates beyond the version that's on the above mentioned release page as of this date (FreeCAD_0.19.17352_x64_LP_11.11_PY2QT4-WinVS2013.7z)
    7. Windows display driver
      There are issues with Radeon graphic cards. If your objects show transparency where they should not, it may be caused by the Radeon driver.

      Workaround: Rollback to an earlier driver graphic card driver version.
      SirSpamalot wrote: Tue Aug 28, 2018 10:46 pm I have a Radeon RX 460 card. It appears that I updated the driver on July 23, 2018. The updated driver was version 24.20.12019.1010 (from Radeon Driver Package 18.7.1). I rolled it back to the version that was previously installed, 21.19.407.0, and that resolved the problem. I then rolled it forward to 24.20.11016.4 (from Radeon Driver Package 18.5.1) and I still don't have the problem. Yay!
      Here is another report of issues with a Radeon 5470 and a driver solving it: ... 44#p264835

      A user from the german forum has successfully installed the current driver version 18.12.2 including. Relive für his Radeon R9 380.

      Radeon Vega 64 is said to be working with driver version See ... 40#p281540
    8. Windows: screen going black
      This is again a display driver issue in connection with Qt5.

      Workaround 1: Try a Qt4 version of Freecad from the development versions.

      Workaround 2:
      Use a different version of opengl32.dll as described in this post.

    9. FreeCAD doesn't start after install
      FreeCAD won't run in Windows 7 if you have "Classic View" enabled.

      Workaround: According to this topic switching to the "Aero" theme helps.

    10. View keeps spinning and/or zooming

      Workaround 1: Make sure you disconnect all additional devices, such as Joysticks. See

      Workaround 2: There was one case reported where leftovers from an autodesk installation caused such behaviour and the registry had to be cleaned; see ... 03#p476992 (German).
    11. The code execution cannot proceed because xxxx was not found When trying to run 0.19_pre on Windows this output has been reported. This is due to FreeCAD not finding relevant .dlls
      Workaround 1: According to the same thread:
      Either you copy all dlls from the libpack's bin directory to FreeCAD's bin directory or to save disk memory set the PATH environment variable to include the libpack's bin directory.
      Workaround 2: According to ... 18#p389721, you may check if the missing dll is provided by Micrososft. Download and install it.
    12. Crash in 0.18.4 when using Arch material tool

      Use 0.18.5 or latest 0.19
    13. Settings for HiDPI displays
      see ... 58#p366158

      1. Close FreeCAD
      2. Right click on the desktop shortcut for FreeCAD
      3. Properties
      4. Go to "Compatibility" tab
      5. "Change high DPI settings"
      6. Enable the option "Use this setting to fix scaling problems for this program instead of the one in Settings"
      7. Click OK to close dialogs
      8. Launch FreeCAD again (from the shortcut)
    14. Freecad does not start or does not open a new file or 3d-view
      It was reported with multiple graphics cards for Nvidia Optimus hybrid and AMD Radeon graphics cards.
      This can occur all of a sudden if some other software is installed.

      On these hybrid systems applications can use both graphic cards. They use in standard mode only the internal Intel HD, and delegate accellerated operations to the Nvidia card.
      See also this posts in the german forum and this one with detailed descriptions.

      Solution (Nvidia):
      You have to correct a misconfiguration of the driver settings. Please add freecad executables to the programs which need 3d-acceleration. You can use the right mouse context menu and select execution with Nvidia. See also Nvidia knowledgebase

      Solution (AMD Radeon):
      Similar as above configure on which graphics card FreeCAD runs; see ... 04#p489133
    15. Crash in Draft or Arch workbench
      According to the research in the topic Draft WB crashes in 0.19.22670 it is again an OpenGL issue.

      No solution yet.
    16. FreeCAD does not start; an error is shown in the log:

      Code: Select all

      Log: Cannot create directory C:\Users\nonAsciiUserName\AppData\Roaming\FreeCAD\webdatapersistent. Error: FILE_ERROR_ACCESS_DENIED.
      This can be caused by a username with non ASCII characters, such as Korean, Cyrillic.

      Start FreeCAD from a username with ASCII characters only.
    17. FreeCAD does not start or doesn't open certain workbenches, message "%1 is not a valid Win32 application"
      The reason is a not matching Python version in %APPDATA%\Roaming\Python\Python38
      References: ... 60#p447360

      Remove the complete folder or at least %APPDATA%\Roaming\Python\Python38\site-packages
    18. FreeCAD takes very long on startup
      This can be caused by an unconnected network, see ... 18#p450693 in German forum.

      Remove the unconnected network.
    19. Numerals are displayed in an unreadable font
      References: ... 20#p382929 ... 84#p508884

      You have to set the correct Language for non-Unicode programs. Go into clock and region settings; click on Formats then change to chosen language and restart.
  • MacOS
    1. MacOS: FreeCAD can't be opened, because it is from an unidentified developer
      MacOS Catilina (10.15):” can’t be opened because its integrity cannot be verified
      Solution: Depending on your system settings there are different things you can do:
      • Rightclick on the app and select "Open". Then you get a dialog where you can confirm to open anyway.
      • According to this post the quarantine flag has to be removed:

        Code: Select all

        sudo xattr -d /Applications/
      • According to this post the system settings can be changed:
        1. Open System Preferences
        2. Open Security & Privacy
        3. Unlock to make changes
        4. This makes active the two buttons midway down and you can selected bottom button 'App Store and identified developers'

        Now you may open FreeCAD in the way described in the points directly above.
    2. MacOS: freezing for about a minute on MacOS Mojave (10.14)
      Opening a system dialog on these systems can take extremely long.

      Workaround 1: start FreeCAD from a console or batch file.

      See and ... 05#p329405 for details.

      Workaround 2: create an alias to the executable, see ... 05#p406100.
      1. Navigate to the "Applications" folder or whereever the directory containing the FreeCAD app is.
      2. Right click on the FreeCAD Application and select "Show Package Contents". (Note: a package is really just a directory of files that is double clickable to launch the app). This allows you to navigate down into the subdirectories.
      3. Open the Contents folder.
      4. Open the MacOS folder.
      5. Right-click on FreeCAD executable and select "Make Alias"
      6. Move that "FreeCAD alias" to your desktop or another place of your desire, from where you can start it with a double click

      Workaround 3: add/modify the certificate associated with FreeCAD, see ... 3#pr406476. This workaround can help if the previous causes issues with menues disappearing or not working.

      Open a terminal, cd to the directory with the FreeCAD application (or use the full path) and enter this:

      Code: Select all

      codesign --force --deep -s -
      Workaround 4: Remove from macOS Preferences > Security & Privacy > Privacy tab > Accessibility menu item;
      click Deny if prompted by macOS to grant FreeCAD access to "whatever it is called" that adds FreeCAD to that list in the first place.
    3. MacOS: Reboot on certain operations
      It was reported in one case that FreeCAD rebooted while working in FreeCAD.

      Solution: This is not a FreeCAD issue. It was caused by an overful Desktop folder. For details see the linked forum post.
    4. MacOS: The desktop or another 3D image is shining through

      Workaround 1: See ... 10#p422710. After starting FreeCAD open a file from the recent files list. You can close it immediately and open a file via menu->open.

      Workaround 2: See ... 83#p422783. It seems to happen if PartDesign is the default workbench to start in. Change the default to Start workbench and switch to PartDesign later.
    5. Enable macos native dark mode on MacOS:
      Solution: Run this in

      Code: Select all

      defaults write freecad NSRequiresAquaSystemAppearance -bool FALSE
    6. Main window is empty (after having installed dark mode)
      Removing config files doesn't help.

      Workaround 1:
      Revert from dark mode with

      Code: Select all

      defaults write freecad NSRequiresAquaSystemAppearance -bool TRUE
      See ... 13#p500413 .
    7. SOLVED:

      FreeCAD 0.19 doesn't run on MacOS Big Sur

      Workaround 1: Use FreeCAD 0.18.
      Workaround 2: Compile yourself using Homebrew, see e.g. ... 63#p444758. Alas this will leave you with an outdated version.
Last edited by Kunda1 on Fri May 06, 2022 3:46 pm, edited 1 time in total.
A Sketcher Lecture with in-depth information is available in English, auf Deutsch, en français, en español.