[Merged] [PR #3822] Strange behavior of copyObject

Merged, abandoned or rejected pull requests are moved here to clear the main Pull Requests forum.
carlopav
Veteran
Posts: 2032
Joined: Mon Dec 31, 2018 1:49 pm
Location: Venice, Italy

Re: [PR #3822] Strange behavior of copyObject

Post by carlopav »

wmayer wrote: Sun Aug 30, 2020 11:00 am If not, doesn't it make sense to make sure that a part container or body object always have its own origin?
Hello Werner, any other thought on this?
In https://forum.freecadweb.org/viewtopic. ... 01#p463601 an user is affected by this "bug".
We can change the default of Draft to always copy dependencies, but in my opinion the doc.copyObject API still will result in a "broken" part when used...

Is it good to you to merge this PR ?
follow my experiments on BIM modelling for architecture design
wmayer
Founder
Posts: 18643
Joined: Thu Feb 19, 2009 10:32 am

Re: [PR #3822] Strange behavior of copyObject

Post by wmayer »

carlopav wrote: Is it good to you to merge this PR ?
Yes, merged now.
carlopav
Veteran
Posts: 2032
Joined: Mon Dec 31, 2018 1:49 pm
Location: Venice, Italy

Re: [PR #3822] Strange behavior of copyObject

Post by carlopav »

wmayer wrote: Sun Jan 24, 2021 10:57 am
carlopav wrote: Is it good to you to merge this PR ?
Yes, merged now.
Many thanks!
follow my experiments on BIM modelling for architecture design
User avatar
Kunda1
Veteran
Posts: 12568
Joined: Thu Jan 05, 2017 9:03 pm

Re: [Merged] [PR #3822] Strange behavior of copyObject

Post by Kunda1 »

Moved to Archived Pull Request subforum. Marked as [Merged]
Alone you go faster. Together we go farther
Please mark thread [Solved]
Want to contribute back to FC? Checkout:
#lowhangingfruit | Use the Source, Luke. | How to Help FreeCAD | How to report FC bugs and features
Post Reply