Import Part Errors when using A2plus Workbench

Discussion about the development of the Assembly workbench.
Post Reply
ruchg
Posts: 26
Joined: Wed Nov 02, 2016 11:26 am

Import Part Errors when using A2plus Workbench

Post by ruchg »

Start FreeCAD
Switch to A2plus Workbench (mine shows V0.4.54b)
Create new empty document
Press Add a Part from an External file
Save current drawing per instructed pop-up
Press Add a Part from an External file
Navigate to file and select

Report View shows a number of errors:
Running the Python command 'a2p_ImportPart' failed:
Traceback (most recent call last):
File "/home/ruchg/.FreeCAD/Mod/A2plus/a2p_importpart.py", line 736, in Activated
importedObject = importPartFromFile(doc, filename)
File "/home/ruchg/.FreeCAD/Mod/A2plus/a2p_importpart.py", line 372, in importPartFromFile
topoMapper.createTopoNames()
File "/home/ruchg/.FreeCAD/Mod/A2plus/a2p_topomapper.py", line 599, in createTopoNames
tempShape = self.makePlacedShape(ob)
File "/home/ruchg/.FreeCAD/Mod/A2plus/a2p_topomapper.py", line 369, in makePlacedShape
plmGlobal = obj.Placement

'App.DocumentObjectGroup' object has no attribute 'Placement'


A part is visible in the drawing view, however there has been a second drawing tab started and made current
DrawingTabs.png
DrawingTabs.png (4.11 KiB) Viewed 1926 times
When I switch back to the assembly drawing there is nothing visible, even after pressing Fit Whole Content on Screen

When I look in the Model Tree I see the added part
DrawingTabs.png
DrawingTabs.png (4.11 KiB) Viewed 1926 times
I don't understand why the part in the Model Tree uses an Sketch Icon instead of the Body Icon a similar assembly of mine uses. The only differrence is that I have used a cutting plane and sliced the foot part and did not on the other assembly parts.

How do I clear the ImportPart Errors?

Thanks.
Attachments
ShortFoot.FCStd
(39.99 KiB) Downloaded 44 times
MidFoot.FCStd
(100.8 KiB) Downloaded 51 times
ModelTree.png
ModelTree.png (25.22 KiB) Viewed 1926 times
User avatar
FaDa3D
Posts: 649
Joined: Tue Aug 08, 2017 8:21 am
Location: Savoie France

Re: Import Part Errors when using A2plus Workbench

Post by FaDa3D »

Hello,
I have the same problem :
I am trying to assemble three sub-assemblies: the first has 40 components, the second 9 and the third 12. See images.
The assembly of the first two is going well. The third does not join the general assembly window and is displayed in a different window. In the combined view, the third component of the general assembly shows a sketch icon ?? The report view informs of an index outside of a range. See picture.

Are there too many components?

Code: Select all

OS: Linux Mint 19.3 (X-Cinnamon/cinnamon)
Word size of FreeCAD: 64-bit
Version: 0.20.28810
Build type: Release
Branch: master
Hash: 30b0efe02557da6438f9d8dc914b1e2acf5f0d9a
Python 3.6.9, Qt 5.9.5, Coin 4.0.0a, OCC 7.5.2
Locale: French/France (fr_FR)
Installed mods: 
  * Curves 0.4.3
  * CurvedShapes 0.4.56
  * fasteners 0.3.41
  * ThreadProfile 1.81.0
  * A2plus 0.4.56
Attachments
Capture du 2022-05-11 16-47-32.png
Capture du 2022-05-11 16-47-32.png (150.99 KiB) Viewed 283 times
Capture du 2022-05-11 16-48-10.png
Capture du 2022-05-11 16-48-10.png (69.07 KiB) Viewed 283 times
Capture du 2022-05-11 16-49-30.png
Capture du 2022-05-11 16-49-30.png (67.02 KiB) Viewed 283 times
Capture du 2022-05-11 16-51-49.png
Capture du 2022-05-11 16-51-49.png (115.94 KiB) Viewed 283 times
Capture du 2022-05-11 16-58-35.png
Capture du 2022-05-11 16-58-35.png (34.88 KiB) Viewed 283 times
Fada de 3D.
Linux Mint
Post Reply