Search found 4059 matches

by kisolre
Fri Aug 05, 2022 2:05 pm
Forum: Help on using FreeCAD
Topic: [bug] Cyclic reference with subshapebinder in new file.
Replies: 8
Views: 439

Re: [bug] Cyclic reference with subshapebinder.

@chrisb you are correct.
New steps to reproduce:
Create new file.
Create new part container, create new body under it.
Create new sketch under the body, exit edit mode.
Create new body under same part.
With the second body active select sketch from first body and try to create SubShapeBinder - error.
by kisolre
Fri Aug 05, 2022 10:53 am
Forum: Help on using FreeCAD
Topic: Techdraw Problem Calculating Area
Replies: 6
Views: 422

Re: Techdraw Problem Calculating Area

So maybe, just maybe there is a forbidden border element somewhere? Like a zero length line, self intersecting spline, ...? How could anyone guess without a file, FC version info, steps to reproduce? Seen the IMPORTANT banner and link on top of the page?
by kisolre
Fri Aug 05, 2022 10:47 am
Forum: Help on using FreeCAD
Topic: [bug] Cyclic reference with subshapebinder in new file.
Replies: 8
Views: 439

Re: [bug] Cyclic reference with subshapebinder.

@mfro FC info?
@Bance that is some 700 commits behind. Maybe some weird logic was introduced in the mean time...
by kisolre
Fri Aug 05, 2022 9:22 am
Forum: Help on using FreeCAD
Topic: [bug] Cyclic reference with subshapebinder in new file.
Replies: 8
Views: 439

[bug] Cyclic reference with subshapebinder in new file.

Edit: happens only with new file, see posts below. I am trying to create a piece that will consist of two bodies, glued together to form a single part. So naturally i wanted to model then as separate bodies under a single Part container. But since they are interdependent I wanted to reference a sket...
by kisolre
Wed Aug 03, 2022 8:12 am
Forum: Help on using FreeCAD
Topic: Empty fusion - exception and pling icon?
Replies: 9
Views: 660

Re: Empty fusion - exception and pling icon?

All those operations make perfect sense with 1 or zero inputs so limiting the user is not necessary.
by kisolre
Tue Jul 12, 2022 7:57 pm
Forum: Help on using FreeCAD
Topic: [Gui] New transparency property not applied
Replies: 13
Views: 670

Re: [Addon problem] New transparency property not applied

Yes, I also have "Random color" active.
by kisolre
Mon Jul 11, 2022 8:27 pm
Forum: Help on using FreeCAD
Topic: [Gui] New transparency property not applied
Replies: 13
Views: 670

Re: New transparency property not applied

Syres wrote: Mon Jul 11, 2022 7:00 pm Could it be one of your many Addons causing the issue?
Sadly looks like it. I tried vanila config and it works. No time to investigate now :(
by kisolre
Mon Jul 11, 2022 6:34 pm
Forum: Help on using FreeCAD
Topic: [Gui] New transparency property not applied
Replies: 13
Views: 670

[Gui] New transparency property not applied

Edit: looks like the problem is from some of the addons that i have. No time to investigate now. Somebody might try the differences between mine, their and DrMacros combinations. There is a new "transparency" setting under "PD/shape appearance" which I waited a lot to appear. But...
by kisolre
Thu Jun 16, 2022 11:48 pm
Forum: Help on using FreeCAD
Topic: Sketch in Origin object, XY_Plane outside Body
Replies: 8
Views: 331

Re: Sketch in Origin object, XY_Plane outside Body

Group property is quite powerful for a lot of things :) Also each features BaseFeature property. Done some weird word sensored lately with that.